Back to overview
Degraded

Intermittent errors during end calls.

Mar 18 at 04:29pm PDT
Affected services
Vapi API

Resolved
Mar 18 at 04:36pm PDT

Resolved now.

RCA:
Timeline (in PT)
4:10pm New release went out for a small percentage of users.
4:15pm Our monitoring picked up increased errors in ending calls.
4:34pm Release was auto rolled back due to increased errors and incident was resolved.

Impact
Calls to end with unknown-error
End of call report was missing

Root cause:
A missing DB migration caused issues in fetching data during end of call.

Remediation:
Add CI check to make sure we don't release code when the dependent DB migration hasn't been run yet.

Created
Mar 18 at 04:29pm PDT

We are investigating a increased cases of call drops. Will post updates soon.