Back to overview
Degraded

Issues with KYC verification

May 01 at 11:41am PDT

Resolved
May 01 at 04:10pm PDT

The team has applied a fix to frontend issue. Root cause was a change related to authentication handlers. Additionally, our KYC vendors are extending observability features in their SDK

Updated
May 01 at 01:44pm PDT

We've narrowed down the issue and are working on a fix. As a mitigation, the KYC flow will "fail closed" to blocking high-risk users; said users will proactively receive and email from our Support team.

Updated
May 01 at 11:56am PDT

We've identified the issue with downstream KYC provider. Working with them to resolve

Created
May 01 at 11:41am PDT

Some self-serve users are unable to sign-in as the KYC verification pop-up is not surfacing correctly at this time. The team has reproduced and is debugging