Calls are degraded on Daily channel
Resolved
Feb 26, 2026 at 1:59am UTC
We have not seen the issue since ~3:50pm today. We have determined the root cause and are rolling out a fix to improve stability in the daily channel.
Incident Report — Daily Channel Call Failures (February 25, 2026)
Impact
Between 7:27 AM – 3:59 PM PST, approximately 19,527 calls failed on the Daily channel due to call worker failures.
All Daily channel users were impacted. The Weekly channel was not affected.
Timeline (all times in PST)
7:27 AM — Degraded call reliability detected on the Daily channel. Status page updated and investigation begins immediately.
8:33 AM — Issue escalated. Team recommends affected customers switch to the Weekly channel while investigation continues. Status page updated.
9:04 AM — Team begins proactive outreach to guide affected customers to the Weekly channel.
10:55 AM — Additional call failures observed on Daily after a brief period of stability. Investigation continues.
11:00 AM — Rolled back previous deployment. Did not observe any significant improvement.
1:30 PM — Continued investigating the issue.
3:59 PM — No further issues observed.
6:00 PM — Released a fix to improve stability in the Daily channel. Incident resolved.
What Went Well
- The issue was detected and acknowledged quickly.
- A dedicated incident response was organized promptly to focus investigation.
- Teams were notified early and guided affected customers to switch to the Weekly channel.
Action Items
- Isolate background operations from call handling
- Strengthen deployment validation
- Improve resilience under load
- Expand monitoring and alerting
Note
This report is intended as a summary of the incident timeline, impact, and immediate action items. A deeper root cause analysis is available upon request.
This issue impacted the Daily channel only. Customers desiring increased stability (at the cost of delayed access to features) can switch to the Weekly channel by navigating to Organization Settings on the Vapi Dashboard and changing the Channel to "weekly".
Affected services
Updated
Feb 25, 2026 at 7:12pm UTC
We are seeing intermittent failures related to the earlier incident, slightly higher than normal amounts. The team is investigating and will share additional updates here.
Degradation is still limited to daily channel. If you are seeing instability we suggest switching to the weekly channel (in Organization Settings → Channel).
Affected services
Updated
Feb 25, 2026 at 4:56pm UTC
The issue is resolved, the team is monitoring and continuing to work on a fix for the recurrent issue.
Affected services
Updated
Feb 25, 2026 at 4:33pm UTC
We have identified the root cause. We did see the issue spike up again during investigation. The team is working on a fix and will update here.
In the meantime we suggest customers switch to the Weekly channel for more stability.
Affected services
Created
Feb 25, 2026 at 3:27pm UTC
We are seeing calls being dropped on the Daily channel with ended reason "call.in-progress.error-vapifault-worker-died". The team is looking into it and will update here.
Affected services