Back to overview
Degraded

High latency retrieving call logs

Jun 26, 2026 at 7:55pm UTC
Affected services
Vapi Dashboard

Updated
Jun 26, 2026 at 8:51pm UTC

We have identified the root cause of this issue and are working to deploy a fix.

Created
Jun 26, 2026 at 7:55pm UTC

We are investigating reports of high latency when viewing logs within the dashboard. At this time we do not see any impact to call success rate, this issue appears isolated to accessing logs of calls once completed.