Back to overview
Degraded

Degraded Performance on Inbound Calls

Apr 16, 2026 at 2:45pm UTC
Affected services
Vapi Numbers Inbound
SIP Inbound
Twilio Inbound
Telnyx Inbound
Vonage Inbound

Resolved
Apr 16, 2026 at 5:00pm UTC

We have now resolved this incident. Between ~7:30AM PT and ~9:30AM PT, a new query pattern caused database slowness that increased API latency and led to dropped inbound calls with certain providers. We mitigated by rolling back the deployment and are following up with a deeper review of the query change.

Updated
Apr 16, 2026 at 3:35pm UTC

We are observing systems recover and performance is returning to normal. Some users may still see brief residual impact as systems stabilize.

Created
Apr 16, 2026 at 2:45pm UTC

We are investigating reports of degraded performance affecting a subset of calls. Our team is actively working to determine the root cause and will provide updates as we learn more.